Spotlight @) SyTech
XLReporter Security Features for 21CFR Partl11

Overview

21CFR Part11 is a FDA regulation on electronic records and electronic signatures. This defines the criteria
under which electronic records and electronic signatures are considered trustworthy, reliable and equivalent to
paper records.

The following document highlights the security features of XLReporter that can help satisfy this regulation.

Security Features
The following security features are available:

e User Accounts

This restricts the capabilities of specific users.
e Access Security

This restricts access to templates and reports.

e Audit Trail
This maintains a log of user activity including configuration changes and electronic signatures.

e File Version Control
This archives configuration files when changes are made. Versioning is applied and rollback is available.

e Electronic Signatures (eSignatures)
This applies electronic signatures to completed reports.

User Accounts
User accounts can be used to restrict the capability of a user based on credentials.

User accounts can be defined as part of the project, in the Project Explorer, under the Project tab by selecting
User Accounts.

By default user accounts are not enabled so the first time this is accessed, you are prompted to Enable User
Accounts and to set an Admin Password.

Add User " Modify User Delete User | " Modify Groups Maximum Clients : 5
User Mame Member Of Expires
#
:l— Enable User Accounts
Admin Password |essse 7
oK Cancel
< >

Once enabled, whenever this application is opened you will be prompted for the Admin Password.
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User Groups
Each user belongs to a group. The group defines the capabilities for each user belonging to it. Click Modify
Groups to access groups.

Edit User Groups n
Group Names Pemissions Allow
Administrators Access to development tools. O
Managers Report : Produce reports on-demand
Uzers Report : Publish on-demand reports to the server
Viewers Report : Blectonically sign {eSian) reports O
Group 5 Wiew : View workbooks produced al i by schedule
Group & View : View reports produced manually by users O
Group 7 Wiew : Publish reports to the server
Group 8 View : Edit and save scheduled reports O
Group 5 Form : Edit and save data entry forms
Group 10 Form : Lock completed data entry forms O
Group 11 PDF : View PDF reports 1
Group 12 Web : View Web reports O
Group 13
Group 14
Group 15

By default the following groups are defined:

e Administrators

e Managers

e Users

e Viewers

e Group5—Group 15

Except for Administrators, the name of every other group listed can be changed by double-clicking on the
name and entering the name you want.

Each available permission is listed on the right with a checkbox to allow or disable the permission for the
group.

Users

There is no limit to the number of users that can be configured for the project. To define a new user, click the
Add User button.
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Edit User

Login Name: Password:

|Fred | | (L1} ~ |
First Name: Last Name:
Fed | [y |
Email: Member of :
| | | Managers ~ |
Comment: Language:

Flart 3 Lead Operator
Account Expires

5/ 7/2030 ~ |[] disable accourt

Enable eSignature
Signature Name:;
[Fred m |

Title:

|Lead Operator |

Fin Code: Fole: v ’

|"0 ‘7| |Re\riew V| u

Signature Image:

|C\XLRprojects\XLR_Demo'\Data\e Sig-Fred JPG |0
=

The Member of setting defines what Group the user belongs to.

If eSignature is enabled for the user, the Signature Name, Title and Signature Image will appear on any report
when signed by this user. Please note that this option is only enabled if the user is a member of a group that
has the Report: Electronically sign (eSign) reports privilege.

The Pin Code is used to verify the user when they attempt to electronically sign a report.

When electronic signatures are applied to a report one or more roles can be defined for the process. A user
can be assigned a specific role or assigned All roles. The following roles are available:

e Accept

e Review

e Approve
Log On/Off

Once user security is enabled you will have to log in to the Project Explorer otherwise virtually no application
will be accessible.

Access Security

Access security is used to protect templates and the reports that are generated from them. By default there is
no restriction on opening templates and reports for viewing and editing. Once access security is enabled,
users will be prompted to enter a password to access.

Access security is enabled in the Project Explorer under the Project tab by clicking Security.
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Settings
General Securty Workbook Reports  PDF Repots  Web Portal

Security Options

File Version Control

Blectronic Signatures
Audit Trail

Workbook Access Protection

| ok || cancel |

To enable, check Workbook Access Protection and enter an Access Code. This code will now be required to
open either a template or a report.

To protect PDF reports, select the PDF Reports tab.

Settings
General Securty Workbook Reports FDF Reports  Web Portal

Folder: [c\XLRprojects\XLR_Demo\PDF il|

PDF Access Protection

Access Code |

Pemission Code

Encryption Permission

40 Bit

128 Bit Allow Copying/Exiraction

ow Annotation

Check the PDF Access Protection option and apply an Access Code.

Audit Trail

The audit trail maintains a log of user activity on configuration changes and electronic signatures. This requires
the Audit Trail connector to be defined in the project.

Audit Trail Connector
Connectors are accessed in the Project Explorer, under the Data tab by clicking Connectors.

A new connector is created by clicking the Add button.
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The Audit Trail connector is available under the XLReporter folder.

Audit Trail *

Connector Name |XLFLﬂud'rt |

Description ‘

Primary Database
Folder |C:\XLRpmjed5\XLR_Demo\Data | |:|

G

The Folder defines where the audit trail database will be stored. By default this is set to the Data folder of the
project and in most cases should not be changed.

Viewing the Audit Trail
The audit trail can be viewed at any time from the Project Explorer, under the Home tab by clicking Audit.

Audit Trail Viewer

1 Refresh & |+ Export
+ [Hip=e 5/7/2020528PM  Fred Muray  SECUR.. Electronic Signature Enabled

Fitter B/7/2020 517 FM Fred Mumay VERSION Process InSight_Page1.gp.1 Minor modification

Stat 07 May 2020 00:00:00 [+ 57/2020511PM  FredMuray ~ SECUR.. Becronic Signature Disabled
I@ 5/7/2020 453 PM  Fred Muray SECUR... Electronic Signature Enabled

@ G A4 p - p Y/2020459FM  FedMuray  SECUR.. File Version Control Enabled
5/7/2020 4:58 PM Fred Mumay SECUR... Workbook Access Protection E...

(5] Parameter
Setting Walug
Audit Type %
Owner %
Template %

Close

To view, specify a time period and some filters and then click Refresh to view items recorded in the audit trail.
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File Version Control
File version control archives configuration files with versioning and the option to rollback. This also provides
an audit trail of configuration changes along with the user who made the change.

Version control is enabled from the Project Explorer under the Project tab by clicking Security.

Settings
General Securty \Workbook Reports  PDF Reports  Web Portal

Security Options
File Version Control
[] Blectronic Signatures
Audit Trai

Workbook Access Protection

Check File Version Control to enable.

Apply Version Control
Once enabled, whenever the configuration of a template, data group or schedule is changed, a prompt

appears to specify a reason as to why this change is happening.

Specify a Reason for the Change ¥

File Name: |F‘roce55 InSight_Page1.gp |

Login Name: |Fred |

Password: | e |

Reason: | Minor modification ~ |

OK || Cancsl

This action is now stored in the audit trail.
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View the File Archive

The file archive can be viewed with the File Archive viewer which can be opened from the Project Explorer
under the Tools tab by clicking File Archive.

File Archive *

Selection

=0 Archive |Daih' Values.ap Ownar: |Fred Murray |
-] History G
E‘ DD! ‘E]r:ilyr‘:"::::les Daily Values gp .1 Archive: |Daih' Values.grp.1 |

[:I History Group Comment: |changed calculation from first sample
to average

Archive Time: |5/11/2020 1:36:06 PM
Write Time: |5/11/2020 1:21:04 PM
Creation Time: |5¢11/2020 1:36:06 PM

On the left side is a list of all the configuration files that have been archived. Once selected, the archived
versions of that file are listed in the middle. When a specific archive is selected, the details from the audit trail
when that file was archived are displayed on the right.

To rollback to an archived version of the file, click the Rollback button.

Electronic Signatures

Electronic signatures are a mechanism that allows users to review and accept completed reports by applying
one or more eSignatures to report documents.

Electronic signatures are enabled in the project by accessing Security from the Project Explorer under the
Project tab.

Settings

General Securty Workbook Reports  PDF Reports  Web Portal

Security Options
File Version Control

Electronic Signatures

Workbook Access Protection

oK || Cancel

Check Electronic Signatures to enable.
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Add Electronic Signatures to a Template
Electronic Signatures are added to a template in the Template Design Studio by clicking General.

General u

Title
Cortrol Chart ‘

Description

The control chart is part of the SPC trends and used to study
how a process changes overtime. Templates for other SPC
trends such as Pareto Chart, SPC Histogram, SPC X Bar R and

Mccess  Signatures

Enable eSignatures

|Reuiew V‘

| Approve e ‘

| > ‘

| ™ ‘

Under the Signatures tab, check Enable eSignatures. Up to four roles can be added for the template.

Now any report automatically generated from the template through the schedule will now require electronic
signatures.

Sign a Report
Reports are signed using the Workbook Report Viewer either on the local machine or on a Windows Team
client.

When the report is selected to view, the signature banner appears at the top indicating the current state of the
signatures for the report.

%) Workbook Report Viewer - Daily Values.xlsx a x
o+ Options <« |l Save < Print ~ = Email |d§ Freeze Panes .ﬁloomln mﬂZaom Out ‘ ‘_-l Keypad
[=)- Mlam Sources -Oiland Gas = A
L2019 -
- Buiding Eneray . B (3} 8] E F G H | ~
2019 > | Values Report
[=)-CIP - Food and Beverage —
L. V12:34 Fermenter | 4 | X X X i
- Daily Values 5 Mixer zone 1 Mixer zone 2 Mixer speed Mixer ram Extruder zone Extruder zone Extruder .
- 5 Date/Time  temperature  temperature (RPM) pressure 1 femperature 2 temperature speed pelils
+ DaywithHoury 6 | 5/10/20 0:00 75.52 7552 3052 82.93 55.51 75.52 7052
- Water Disrbution 7| 510120 1:00 7775 8347 1181 73.69 5716 87.47 8204
22019 8| 51020 2:00 78.82 59.03 4119 64.92 5077 93.03 7196
et s 510120 3:00 22.00 35.00 4357 50,66 45.00 77.41 8124
< T 51020 4:00 76.00 7723 4320 5077 56.46 78.02 8087
1 5/0/20 5:00 77.41 77.41 4547 66.19 56,86 8287 8313
o Refresh L] Store [12] 5/10/20 6:00 70.00 79.78 4399 74.04 57.63 85.24 81.66
Neme (13 510120 7:00 76.00 79.44 4959 83.23 5049 84.90 76.71
TS a 511020 8:00 76.85 8234 56.59 89.54 50.00 87.80 8372
(15| 51020 9:00 77.34 8196 5588 90.77 5015 87.42 8301
(16| 5110120 10:00 40.00 78.33 5387 86.49 57.99 78.16 81,00
7] 5110120 11:00 7826 7875 4100 78.20 5781 78.58 75.78
(18| 5110120 12:00 16.00 90,04 4278 68.79 5758 89.87 7756
19| 5110120 13:00 80.24 8962 4977 6155 56 56 89.45 8455
(20 510120 14:00 78.50 76.92 4474 59.01 57.02 77.88 7952
[21] 5110120 15:00 7854 86.48 4923 62.05 5599 87.44 84.01
[22] 5110120 16:00 76.38 8853 51.00 69.62 5744 89.48 70,71
[23] 510/20 17.00 76.00 8158 4148 79.07 56.60 8253 76.45
124 5/10/20 18:00 76,68 8218 4242 87.00 56.61 8314 7739
25 510120 19:00 76.85 5110 4426 90.90 58 51 92.05 7923
Faal Eranian 200 on P ps oo 1z o an a5 an et
fred W < b n Results I3 >
The banner states are:
e Red no signatures have been applied
e Yellow signatures have been partially applied
e Green signatures are Complete

Copyright © SyTech, Inc. 2020. All rights reserved.



To add a signature to the report, in the banner, click Details.

eSignature Details X
Template Name: [Daly Values |
Report Name ‘DEI'Y Values xlsx |
Report Path: | Daily Values\Daly Values s |
Signee Mame: ‘Mary Wells ‘ REVIEWED
Title: ‘Supemsor
Signed Date:  [5/11/2020 1:29.49PM | Role: [Review
Comment:  |everything is within spec
" -
Add Signature “
Signee Mame: ‘ ‘
Tile: | |
Signed Date: ‘ Role: |Appmwe
Comment:
| Add Signature |
—

This dialog shows all the signature roles required and which signatures have already been applied. Click Add
Signature to add.

Apply Signature *

Template Mame Daily Values

Report Name |Dairy WValues xlsx |
Report Path |Da|?y Values\Daily Values xlsx |

Signee

Login Mame |Fred ‘

Password

eSignature

|

Comment:  |report is complete

If the user logged in has the role indicated then the Login Name and Password are filled in. Otherwise they
are not so a user name with this role must be specified.

The Pin Code must be specified to verify the user and a comment can be added.

Publish a Report
Any time after the report is signed, it can be published as a PDF file. This is done in the Workbook Report
Viewer by clicking the Publish Report button.

The report is published with a signature certificate included. The signature certificate can be customized to fit
your needs.

To do so, open certificate.xIsx from the _library folder of the installation (e.g., C:\XLReporter).

When published, the Signatures worksheet from this workbook is copied to the report workbook. The
eSignature information is written as a single row in the named cell Certificate_Data which by default is $8539.
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